HELPPPP//HELLLPPP Помогите написать программу в паскаль, пожалуйста. В массиве A[1..6]...

0 голосов
74 просмотров

HELPPPP//HELLLPPP Помогите написать программу в паскаль, пожалуйста. В массиве A[1..6] найти сумму положительных элементов, найти сумму положительных элементов, которые которые находятся в диапазоне от -1 до 5 включительно.


Информатика (204 баллов) | 74 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

PascalABC.NET 3.4.2, сборка 1881 от 19.11.2018

Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(6, -10, 10);

 a.Println;

 Writeln('Сумма положительных ', a.Where(t -> t > 0).Sum);

 Writeln('Сумма положительных на [-1;5] ',

   a.Where(t -> (t > 0) and t.InRange(-1, 5)).Sum);

end.

Пример

3 -2 -2 7 3 6

Сумма положительных 19

Сумма положительных на [-1;5] 6

(654k баллов)
0

Спасибо!!!

0

Пожалуйста)

0

Как Вы понимаете, надеюсь) любые условия просто меняются внутри Where

0

спасибо за пояснение)

0

Тогда еще напишу, что в ArrRandom - количество элементов и границы изменения.

0

Массив сразу и создается нужного размера и типа, и заполняется.