Напишите программу, которая предложит пользователю ввести длину строки n и ее члены-целые...

0 голосов
66 просмотров

Напишите программу, которая предложит пользователю ввести длину строки n и ее члены-целые числа, и отобразит на экране следующую информацию: сам массив, среднее арифметическое всех четных чисел


Информатика (9.0k баллов) | 66 просмотров
0

длину строки n - это размер массива?

0

ее члены-целые числа - ввод элементов массива с клавиатуры?

0

да,да.

0

Уже решено сегодня

Дано ответов: 2
0 голосов

javascript:var n = prompt("Введите n:"), массив = [], чётных = 0; for (let сч = 0; сч < n; сч++) массив.push(parseInt(prompt("["+сч+"]:"))); alert(массив + "\n" + (массив.reduce(function (пр, тек) { if (тек % 2 == 0) { чётных++; return пр + тек; } else return пр; }, 0) / чётных));

(654k баллов)
0

А почему я ввожу длину строки 5 и пишу числа: 1,2,3,4,5. Но он выводит среднее арифметическое четных чисел 12, хотя должно быть (2+4)/2=3?

0

Проверяй. "parseInt" куда-то при вставке исчез.

0

Да, работает, спасибо за ещё одно решение.

0 голосов

var a:array of integer;

n,i,s,k:integer;

begin

write('Введите количество элементов массива: ');

readln(n);

a:=new integer[n];

for i:=0 to n-1 do read(a[i]);

write ('Массив: ');

for i:=0 to n-1 do write(a[i],'  ');

writeln;

for i:=0 to n-1 do

if a[i]mod 2 = 0 then

begin

s:=s+a[i];

k:=k+1

end;

writeln('Среднее арифметическое чётных элементов массива равно: ',s/k:0:3)

end.

(3.9k баллов)
0

Спасибо большое.