Информатика.Паскаль.(10-11 класс)1 курс. Помогите пожалуйста написать программу по теме :...

0 голосов
35 просмотров

Информатика.Паскаль.(10-11 класс)1 курс. Помогите пожалуйста написать программу по теме : " Разработка и отладка программ с циклами " . + Если по этой программе можно сделать график , то сделайте пожалуйста хотя бы примерный.


image

Информатика (260 баллов) | 35 просмотров
0

Вычислить все значения и найти среднее арифметическое Y, где Y=A+x^2 где A любое число, x [0,5;4,5] с шагом=0.3.

Дан 1 ответ
0 голосов

Var Y,a,x:real;
c:Integer;
begin
read(a);
x:=0.5;
while x<=4.5 do begin<br> Y:=a+sqr(x);
writeln('x:',x:2:2,' Y:',Y:2:2);
c:=c+1;
x:=x+0.3;
end;
write('Среднее арифмитическое:',Y/c:2:2);
end.



я думаю что эт правильно

(34 баллов)
0

Где ты был раньше(

0

Я уже за это время сам сделал.

0

Но всё равно спасибо).

0

правильно?

0

уже 15 дней прошло когда я ответил