Напишите программу в pascal Задаются границы диапазонанайти сумму тех чисел которые четные

0 голосов
38 просмотров

Напишите программу в pascal Задаются границы диапазонанайти сумму тех чисел которые четные


Информатика (27 баллов) | 38 просмотров
Дан 1 ответ
0 голосов

var a,b,i,z,x:integer;

q:array [1..20] of integer;

begin

 write('Верхняя граница='); readln(a);

 write('Нижняя граница='); readln(b); x:=a-b; randomize;

 for i:=1 to 20 do

 begin  

   q[i]:=random(x)+b;

   write(q[i],' ');

   if (q[i]mod 2=0) then z:=z+q[i];

 end;

 writeln;

 write('Сумма четных чисел=',z);

end.

(2.3k баллов)
0

Помогите пожалуйста с моим вопросом(

0

с каким вопросом?