Помогите составить программу ** языке Паскаль. Дам 20 баллов

0 голосов
12 просмотров

Помогите составить программу на языке Паскаль. Дам 20 баллов


image

Информатика (82 баллов) | 12 просмотров
0

А номера причалов-то где?

0

наверное эти яхты нужно вогнать массив и их номер и будет номером причала

0

Наверное - это я так могу думать. А Вы должны сказать определенно.

0

Номера соответственны порядку в каком стоят числа

Дан 1 ответ
0 голосов
Правильный ответ

PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018

Внимание! Если программа не работает, обновите версию!

begin

 var a := Arr(3.5, 4.2, 5.7, 6.3, 4.5, 7.1, 3.3);

 Writeln('a) ', a.Sum);

 Writeln('б) ', a.Where(t -> t > 5).Sum);

 Writeln('в) ', a.Max);

 Writeln('г) ', a.Where(t -> t < 5).Count);

 Writeln('д) ', a.IndexMin + 1)

end.

a) 34.6

б) 19.1

в) 7.1

г) 4

д) 7

(654k баллов)