Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу,...

0 голосов
37 просмотров

Информатика "Программирование разветвляющихся алгоритмов"

1. Написать программу, определяющую по длинам сторон A. B. C, является ли треугольник равнобедренным.

2. Даны радиусы круга и сторона квадрата. У какой фигуры площадь больше? 3. Даны два различных вещественных числа X и Y. Написать программу возведения наименьшего из чисел в квадрат, наибольшего в куб и нахождения среднего арифметического полученных знаний. Метки:


Информатика (32 баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var a,b,c,r,x,y:integer;

Begin

  read(a,b,c);

  if (a=b) or (a=c) or (b=c) then

     writeln('Ravnobedrennyj');

 

  read(a,r);

  if  (a*a>pi*r*r) then writeln('Kvadrat bolshe')

  else writeln('Krug bolshe');

 

  read(x,y);

  if x>y then writeln(y*y,' ',x*x*x,' ',(x+y)/2);

  else writeln(x*x,' ',y*y*y,' ',(x+y)/2);

End.

 

 

(53.1k баллов)