Написать программу для паскаля. Дана квадратная матрица порядка n(n=5). Если в данной...

0 голосов
41 просмотров
Написать программу для паскаля. Дана квадратная матрица
порядка n(n=5).
Если в данной матрице a нет отрицательных элементов,
то транспонировать её, иначе выдать сообщение.

Информатика (45 баллов) | 41 просмотров
0

что за транспонировать её?

0

Матрица задается с клавиатуры или рандомно?

0

С клавиатуры наверно

0

Kage1998, транспонировать - поменять местами строки и столбцы

0

если бы сказала по быстрее я бы решил эту задачу

0

Если бы Вы были заинтересованы, могли бы и в поиск это слово забить.

Дан 1 ответ
0 голосов

Uses crt;
const N=2;
var a:array [1..N,1..N] of real;
    i,j,k:integer;
begin
     k:=0; writeln('Введите матрицу:');
     for i:=1 to N do
         for j:=1 to N do
         begin
              read(a[i,j]);
              if a[i,j]<0 then inc(k);<br>         end;
     if k>0 then writeln('В матрице отрицательный элемент')
     else
         for i:=1 to N do
         begin
             for j:=1 to N do
             write(a[j,i]:3:0);
             writeln;
         end;
end.      

(7.2k баллов)