Написать программу для паскаля. Дан массив x размера n(n=10) целых чисел, содержащий как...

0 голосов
32 просмотров
Написать программу для паскаля. Дан массив x размера n(n=10) целых
чисел, содержащий как положительные, так и отрицательные элементы. Упорядочить
массив следующим образом: сначала идут отрицательные числа, упорядоченные по
невозрастанию, потом положительные, упорядоченные по неубыванию.


Информатика (45 баллов) | 32 просмотров
Дан 1 ответ
0 голосов

Program gt;
var  A,B,C:array[1..1000]of longint;
  p,l,n,i,j,k,w:longint;
begin
n:=10;
for i:=1 to n do
read(A[i]);
k:=0;w:=0;
for i:=1 to n do
begin
if(A[i]<0)then begin<br>k:=k+1;b[k]:=a[i];
end;
if(A[i]>0)then begin
w:=w+1;
c[w]:=a[i];
end;
end;
for i:=1 to k-1 do
for j:=1 to k-i do
begin
p:=b[j];l:=b[j+1];
if b[j]b[j]:=l;b[j+1]:=p;
end;
end;
for i:=1 to k do
write(b[i],' ');
for i:=1 to w do
write(c[i],' ');
end.

(6.6k баллов)
0

Program sortwhile {input,output};
Const n=10;
Var i: integer;
u: real;
a: boolean;
x: array [1..n] of real;
Begin {*read array X*}
For i:=1 to n do
Read {X[i]};
A:=false;
While not a do
Begin
a:=true;
For i:=1 to n-1 do
If X[i] Then
Begin
u:=X[i];
X[i]:=X[i+1];
X[i]:=u;
a:=false;
End;
End {*while*};
{*Write array X*}
For

0

мое решение правильное хотя там один лишный 12строк

0

Можешь то что я последние добавил переделать в то что ты решил?

0

ну у тебя решение неправильное так как ты просто упорядичеваеш по убыванию

0

я изменил решение если невидно обнови страницу