Написать программу в С++ Описать функцию Otr(Ax,Bx,Ay,By) вещественного типа находящую...

0 голосов
111 просмотров

Написать программу в С++ Описать функцию Otr(Ax,Bx,Ay,By) вещественного типа находящую длину отрезка AB на плоскости по координатам его концов |AB|=sqrt((Ax-Bx)^2+(Ay-By)^2 )(Ax,Ay,Bx,By)- вещественны параметры) с помощью этой функции найти длины отрезков AB,AC,AD, если с клавиатуры заданы координаты точек, A,B,C,D.


Информатика (43 баллов) | 111 просмотров
0

(Ax-Bx)^2 + (Ay-By)^2 точно правильная формула?

0

Ой, из всего этого корень квадратный

0

Bcghfdbk

0

Исправил

Дан 1 ответ
0 голосов
Правильный ответ

#include

#include

using namespace std;


double Otr(double Ax, double Bx, double Ay, double By) {

return sqrt((Bx - Ax)*(Bx - Ax) + (By - Ay)*(By - Ay));

}


int main() {

double Ax, Ay, Bx, By, Cx, Cy, Dx, Dy;

cin >> Ax >> Ay >> Bx >> By >> Cx >> Cy >> Dx >> Dy;

cout << "|AB|=" << Otr(Ax, Bx, Ay, By) << endl;</p>

cout << "|AC|=" << Otr(Ax, Cx, Ay, Cy) << endl;</p>

cout << "|AD|=" << Otr(Ax, Dx, Ay, Dy) << endl;</p>

return 0;

}


image
(654k баллов)
0

Благодарю, еще раз приношу извинения !

0

Дважды-то зачем? ))) Я же писал, что с Паскалем эти языки по сути схожи. Да об этом и сам Дохлый Страус писал.

0

Ну теперь вижу, что действительно похожи!)

0

А до этих пор Вы не верили словам создателя С++ ?

0

Доверяй, но проверяй, как говорится.А так знал это, но на практике не встречался

0

Вот поэтому меня всегда удивляют просьбы переписать с Паскаля в С++ и наоборот.