Турбо Паскаль. Написать программу, которая считает количество буквы в строке. Допустим...

0 голосов
99 просмотров

Турбо Паскаль. Написать программу, которая считает количество буквы в строке. Допустим букву "а" в любом регистре, строка вводится с клавиатуры. входной файл: предложение выходной файл: количество буквы


Информатика (276 баллов) | 99 просмотров
0

Именно файл, клавиатурный ввод и вывод на монитор не устраивают?

0

У Вас противоречие в вопросе. "строка вводится с клавиатуры." и тут же сказано про "входной файл".

0

Вы что, работу с файлами уже изучали? Все эти Assign, Open, Close ?

0

мы отдельно не изучали, мне нужно самой на олимпиаду завтра, можно программу без assign и т.д., вобщем алгоритм только

0

Понятно. Сейчас Вы увидите, что это совсем не одна строка, как "по-современному".

Дан 1 ответ
0 голосов
Правильный ответ

uses Crt;


const

 n=100; { мах длина строки }

 

var

 s:string[n];

 i,k:integer;


begin

 ClrScr;

 Readln(s);

 k:=0;

 for i:=1 to Length(s) do

   if (s[i]='а') or (s[i]='А') then Inc(k);

 Writeln(k);

 ReadKey

end.

(654k баллов)
0

Благодарю, да, явно не одна строка, но именно к такому я привыкла

0

Ну вот видите, Вас приучили "к плохому" )))

0

Вместо того, чтобы писать ЧТО НУЖНО СДЕЛАТЬ, Вас вынуждают описывать КАК ЭТО СДЕЛАТЬ.

0

Но главное - Вы намного больше тратите времени писанину кода и отладку программы а шанс сделать ошибки намного выше. И пока Вы пишите одну программу, Ваши соседи успевают написать три. Или пять.