Напишите программу, которая вводит номер месяца и выводит название времени года **...

0 голосов
122 просмотров

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке. При вводе неверного номера месяца должно быть выведено слово 'NO'.Входные данныеВходная строка содержит единственное число – номер месяца (возможно, неверный).Выходные данныеНужно вывести название времени года (на английском языке), соответствующее введённому номеру месяца ('winter' – зима, 'spring' – весна, 'summer' – лето, 'autumn' – осень). Если введён неверный номер месяца, программы должна вывести слово 'NO'.


Информатика (12 баллов) | 122 просмотров
Дан 1 ответ
0 голосов

Var A:integer;
Begin
Read(A);
A:= A mod 12;
if (A>=0)and(A<3) then Write(Зима);<br>if (A>2)and(A<6) then Write(Весна);<br>if (A>5)and(A<9) then Write(Лето);<br>if (A>8)and(A<=11) then Write(Осень);<br>End.

(30 баллов)