Напишите программу , которая сортирует массив по убыванию суммы цифр числа. Только...

0 голосов
352 просмотров

Напишите программу , которая сортирует массив по убыванию суммы цифр числа. Только полегче для 10 класса. В паскале.Помогите срочно!


Информатика (12 баллов) | 352 просмотров
Дан 1 ответ
0 голосов

function summa(n:integer):integer;

var a,s:integer;

begin

a:=abs(n);

s:=0;

while a>0 do

begin

 s:=s+a mod 10;

 a:=a div 10;

end;

summa:=s

end;

const n=10;

var A:array [1..n] of integer;

   j,i,k:integer;

begin

writeln('Исходный массив: ');

for i:=1 to n do

begin

 A[i]:=random(15)+1;

 write(A[i]:4);

end;

for i:=1 to n-1 do

begin

 for j:=1 to n-1 do

 if summa(A[j])

  begin

   k:=A[j];

   A[j]:=A[j+1];

   A[j+1]:=k

  end;

end;

writeln;

writeln('Отсортированный массив: ');

for i:=1 to n do

write(A[i]:4);

readln

end.

(374 баллов)