Напишите программу, которая заполняет массив из 20 элементов и находит в нём минимальный...

0 голосов
80 просмотров

Напишите программу, которая заполняет массив из 20 элементов и находит в нём минимальный из чётных элементов и его номер. Предполагается, что в массиве есть чётные элементы.


Информатика (35 баллов) | 80 просмотров
0

Какой язык?

0

pascal

Дан 1 ответ
0 голосов
Правильный ответ

PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018

Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(20, -50, 50);

 a.Println;

 var min := a.Where(t -> t.IsEven).Min;

 var i := a.IndexOf(min);

 Writeln('a[', i + 1, '] = ', min)

end.

Пример

39 -37 21 13 26 1 37 -19 21 39 -34 -23 22 46 8 -6 -21 39 47 32

a[11] = -34

(654k баллов)