Напишите программу в pascalСергей страдает ожирением в процессе голодании он каждую...

0 голосов
37 просмотров

Напишите программу в pascalСергей страдает ожирением в процессе голодании он каждую неделю скидывает 3% от предыдущего веса изначально он весил 150 кг в машину он влезет когда будет весить 96 кг Через сколько недель он влезет в машину?


Информатика (27 баллов) | 37 просмотров
Дано ответов: 2
0 голосов

VAR  

MASSA:real;

NED:INTEGER;

BEGIN

MASSA:=150;

NED:=0;

WHILE (MASSA>=96) DO

BEGIN

MASSA:=MASSA-MASSA*0.03;

NED:=NED+1;

END;

WRITELN('Через ',NED,' недель Сергей влезет в машину')

END.

(86 баллов)
0 голосов

var v,z:real;

   i:integer;

begin

v:=150;

while not(v

begin

z:=(v/100)*3;

v:=v-z;

inc(i);

end;

write(i);

end.

(2.3k баллов)