Составить программу Дано число М (М

0 голосов
36 просмотров

Составить программу Дано число М (М<=12). Определить количество дней в данном месяце.


Информатика (97 баллов) | 36 просмотров
Дан 1 ответ
0 голосов

Ну... а что сложного? Создаёшь структуру, заполняешь её, и обрабатываешь условие на входном M:


#include

#include

#include

int main(void) {

setlocale(LC_ALL, "russian");

struct months {

 char name[16];

 int days;

};

struct months m[12] = {

 {"Январь",   31},

 {"Февраль",  29},

 {"Март",     31},

 {"Апрель",   30},

 {"Май",      31},

 {"Июнь",     30},

 {"Июль",     31},

 {"Август",   31},

 {"Сентябрь", 30},

 {"Октябрь",  31},

 {"Ноябрь",   30},

 {"Декабрь",  31}

};

 

int M;

 

printf("Введите номер месяца: ");

scanf("%d", &M);

 

if (M > 0 && M < 13) {

 M--;

 

 if (m[M].days == 29 || m[M].days == 30) {

 printf("В месяце \"%s\" %d дней.", m[M].name, m[M].days);

 } else {

 printf("В месяце \"%s\" %d день.", m[M].name, m[M].days);

 }

} else {

 printf("Неизвестный месяц.");

}

 

getch();

 

return 0;

}

(50 баллов)
0

Извини, этот сайт не поддерживает табуляцию и криво ставит отступы между строками.