Напишите программу, которая считывает с клавиатуры одно дробное число и выводит обратное...

0 голосов
513 просмотров

Напишите программу, которая считывает с клавиатуры одно дробное число и выводит обратное ему. Если при этом введённое с клавиатуры число меньше по абсолютной величине одной миллионной (в частности, если оно равно нулю), вывести вместо этого миллион. Пример Ввод Вывод 0.5 2.0


Информатика (18 баллов) | 513 просмотров
Дан 1 ответ
0 голосов

Var i,x: Integer;
n: Real;
begin
x:=1;
readln(n);
if n<>0 then
begin
while frac(n)<>0 do
begin
n:=n*10;
x:=x*10;
end;
if frac(x/n)=0 then writeln(x/n) else writeln(x,'/',n);
end else
writeln('1000000');
end.

(5.6k баллов)