ПОМОГИТЕ ПЛИЗ Язык программирования - Python Вася решил познать азы ASCII-живописи и, как...

0 голосов
901 просмотров

ПОМОГИТЕ ПЛИЗ Язык программирования - Python Вася решил познать азы ASCII-живописи и, как все начинающие художники, начал с рисования простых фигур. Помогите Васе написать программу построения прямоугольника n х m, состоящего из символов symb. Фигура должна быть пустой, а не заполненной. То есть она должна состоять только из контура. Если поможет, у меня получился алгоритм с закрашенным прямоугольником: x = int(input()) y = int(input()) z = input() for i in range(x): print(z, end='') for j in range(1, y): print(z, end='') print(' ')


Информатика (12 баллов) | 901 просмотров
Дан 1 ответ
0 голосов

m = int(input())

n = int(input())

c = input()

s1 = c * n

s2 = c + (n - 2) * ' ' + c

print(s1)

for i in range(m - 2):

   print(s2)

print(s1)

Это на питоне, лицеист)))

(14 баллов)
0

Тут не так как у тебя