Составить программу. Вывести ** экран 10 первых целых чисел кратных 7 pascal. Если...

0 голосов
74 просмотров

Составить программу. Вывести на экран 10 первых целых чисел кратных 7 pascal. Если правильно дам ещё баллы.


Информатика (103 баллов) | 74 просмотров
Дано ответов: 2
0 голосов

var a,i:integer;

begin

 for a:=14 to 77 do

   begin


   if (a mod 7=0) then

         write(a,' ');

   end;

end.

(2.3k баллов)
0 голосов

var i,k:integer;

begin

repeat

if i mod 7 = 0 then

begin

k:=k+1;

write (i,'   ')

end;

i:=i+1

until k=10

end.

(3.9k баллов)
0

Так короче программа: var k,n: integer;begin repeat n:=n+7; write(n,' '); k:=k+1; until k=10; end.

0

beginwrite (0,' ',7,' ',14,' ',21,' ',28,' ',35,' ',42,' ',49,' ',56,' ',64)end.

0

Так ещё короче... )))

0

А если k = 10000, то как со временем выполнения программы при использовании mod?

0

Пример задачи, где время выполнения существенно, task/30211291.

0

А если надо выбрать числа кратные 7 из произвольного набора чисел?

0

Тогда это уже другая задача.

0

Извините, но так и не поняла, зачем вы презентовали свой вариант программы... Либо вы точно знаете какие числа нужны и тогда непонятен выбор именно данного цикла, либо устраивать проверку на кратность и не придумывать мифические условия...

0

Ведь можно писать и так:beginSeqGen(10, 0, t -> t + 7).Printend.

0

Это уже на паскаль, а PascalABC.NET, а опубликовал - для разнообразия.