Напишите программу, условие задачи в приложении

0 голосов
37 просмотров

Напишите программу, условие задачи в приложении


image

Информатика (463 баллов) | 37 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

PascalABC.NET 3.4.2, сборка 1843 от 24.10.2018

Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger;

 var m := Max(n div 10, n mod 10);

 m *= 11;

 if m < n then Println('NO')

 else Println(m - n)

end.

13

20

(654k баллов)
0 голосов

var a:integer;

begin

readln (a);

if a div 10 = a mod 10 then write ('NO') else

if a div 10 > a mod 10 then write ((a div 10 + a div 10*10)-a)

else write ((a mod 10 + a mod 10*10)-a);

end.

(3.9k баллов)
0

спасибо большое, все работает

0

вы не могли бы подумать еще над этой задачей, если сможете https://znanija.com/task/30194711 заранее спасибо!

0

Вопрос: почему для двух одинаковых цифр у Вас выдается NO? По условию увеличивать можно на любое НЕОТРИЦАТЕЛЬНОЕ число. В данном случае увеличить надо на ноль, а ноль число не отрицательное, значит ответ 0.

0

спасибо за поправку

0

но тогда в каком случае вообще возможен ответ NO

0

Я вообще не смог придумать случай, когда будет NO )))

0

Ну что же, обычное дело: кривое условие. Не впервой)))

0

понятно, спасибо)))

0

Это олимпиады - из из года в год с одними и теми же кривыми условиями переписывают