Помогите составить программу (решить систему уравнений) ** Pascal F(x)=sqr(x)-x, если 0

0 голосов
29 просмотров

Помогите составить программу (решить систему уравнений) на Pascal F(x)=sqr(x)-x, если 0<=x<=1; F(x)=sqr(x)-sin(Pi)*sqr(x), если x>1 или x<0<hr>image


Информатика (79 баллов) | 29 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var x,f: real;

begin

write('x = ');

readln(x);

if (x>=0)and(x

else f:=sqr(x)-sin(pi*sqr(x));

writeln('F = ',f:6:4);

end.

Пример:

x = 0.5

F = -0.2500

(194k баллов)
0

не поможете с блок-схемой?