Задача по информатике олимпиада ПОМОГИТЕ ПОЖАЛУЙСТА Для того чтобы проверить, как её...

0 голосов
175 просмотров

Задача по информатике олимпиада ПОМОГИТЕ ПОЖАЛУЙСТА Для того чтобы проверить, как её ученики умеют считать, Мария Ивановна каждый год задаёт им на дом одну и ту же задачу – для заданного натурального A найти минимальное натуральное N такое, что N в степени N (N, умноженное на себя N раз) делится на A. От года к году и от ученика к ученику меняется только число A. Вы решили помочь будущим поколениям. Для этого вам необходимо написать программу, решающую эту задачу. Формат входных данных На вход подаётся единственное число A (1≤A≤1000000000 – на всякий случай; вдруг Мария Ивановна задаст большое число, чтобы «завалить» кого-нибудь…). Формат выходных данных Вывести единственное число N.


Информатика (85 баллов) | 175 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

A = int(input())

N = 1

while (N**N) != ((N**N) // A ) * A:

   N = N + 1  

print(N)

(60.5k баллов)