Составьте программу ** Паскале, которая вводит 2 целых числа M и N и печатает все целые...

0 голосов
28 просмотров

Составьте программу на Паскале, которая вводит 2 целых числа M и N и печатает все целые числа между M и N, делящиеся на 7, включая и сами эти числа. Замечание: программа должна учитывать, что заранее не известно, какое из чисел M или N больше другого.


Информатика (74 баллов) | 28 просмотров
Дан 1 ответ
0 голосов

var

   N, M, prov: longint;

begin

   readln(N);

   readln(M);

   if N < M then

   begin

       prov := N;

       while prov

       begin

           if prov mod 7 = 0 then

               writeln(prov);

           inc(prov);

       end;

   end

   else  

   begin

       prov := M;

       while prov

       begin

           if prov mod 7 = 0 then

               writeln(prov);

           inc(prov);

       end;

   end;

end.

(4.1k баллов)