CРОЧНО РЕШИТЬ ** ПАСКАЛЕ !!!!! 123456 234561 345612 456123 561234 612345 решить матрицу

0 голосов
47 просмотров

CРОЧНО РЕШИТЬ НА ПАСКАЛЕ !!!!! 123456 234561 345612 456123 561234 612345 решить матрицу


Информатика (37 баллов) | 47 просмотров
0

что значит "решить матрицу"?

0

сформировать матрицу и составить программу

0

а что эта программа должна делать?

0

(123456234561345612456123561234612345) вот эти числа, являются ответами программы, то есть вывод программы. А что она делает, должно быть похоже, как на магический квадрат, но не совсем.

Дано ответов: 2
0 голосов
Правильный ответ

PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018

Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrGen(6, t -> t + 1);

 var b := new integer[6, 6];

 for var i := 0 to 5 do

 begin

   b.SetRow(i, a);

   a := a[1:] + a[:1] // циклический сдвиг влево на 1 позицию

 end;

 b.Println(2)

end.


image
(654k баллов)
0 голосов

Program SyrnayaBulka;  

var i,j,k:integer;


   s:string;


begin


s:='**** -=Alphaeus=- ****';


for i:=1 to 22 do begin write(s[i]); sleep(67) end;


writeln;writeln;


 for i:=1 to 6 do


   begin


     write('     ');


     for j:=1 to 6 do


       begin


         k:=i+j-1;


         if k>6 then k:=k-6;


         write(k,' ');


       end;  


     writeln;


   end;


end.


image
(52.6k баллов)