Помогите написать программу (Паскаль), которая посчитает сумму пяти разных чисел, который...

0 голосов
87 просмотров

Помогите написать программу (Паскаль), которая посчитает сумму пяти разных чисел, который может ввести пользователь самостоятельно. Написать программу для трех случаев, с циклом while, repeat и for


Информатика (18 баллов) | 87 просмотров
Дан 1 ответ
0 голосов

program a1;

var

 i,n,s: integer;

begin

 writeln('Введите 5 чисел');

 

 for i:=1 to 5 do

 begin

   read(n);

   s+=n

 end;

 

 Writeln(s);

 

 

 writeln('Введите 5 чисел');

 s:=0;

 i:=1;

 

 while i

 begin

   read(n);

   s+=n;

   i+=1

 end;

 

 Writeln(s);

 

 writeln('Введите 5 чисел');

 s:=0;

 i:=0;

 

 repeat

   i+=1;

   read(n);

   s+=n;

 until i=5;

 

 Writeln(s)

end.

(2.5k баллов)