Помогите написать программу Паскаль,очень прошу,вообще не шарю в программах,а так 2...

0 голосов
52 просмотров

Помогите написать программу Паскаль,очень прошу,вообще не шарю в программах,а так 2 поставят!!!Задача «A»: Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15. Задача «B»: Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите натуральное число: 12342 Нет. Пример: Введите натуральное число: 12245 Да.


Информатика (50 баллов) | 52 просмотров
0

и правильно сделают, это плохо если совсем не "шарите", хотя с другой стороны может и хорошо, а зачем вам другая оценка, она же будет все равно не ваша

Дано ответов: 2
0 голосов

A)

var num, sum, i, temp: Integer;


begin


print('Number: ');


readln(num);


temp:= num;


i:=1;


while(temp <> 0) do


 begin


 temp:= temp div 10;


 if(temp =0) then break;


 i:= i+1;


 end;


temp:= i;


sum:=0;


for i:=0 to temp do


 begin


 sum:= sum + (num mod 10);


 num:= num div 10;


 end;


println('Sum: ',sum);


end.


B)


var num, temp: Integer;

   bool:boolean;    

begin

readln(num);

temp := num mod 10;

num := num div 10;

while(num<>0) do

 begin

 if (temp = num mod 10)  

   then

   begin

   bool:=true;

   break;

   end;

 temp := num mod 10;

 num := num div 10;

 end;

if bool then write('Yes') else write('No');

end.

(45 баллов)
0 голосов

begin

 var s := ReadString('n =');

 s.Aggregate(0, (Sum, x)-> Sum + x.toDigit).Println;

 

 var i := 2;

 while (i <= s.Length) and (s[i] <> s[i - 1]) do i += 1;

 

 Print(i > s.Length ? 'No' : 'Yes')

end.

(2.5k баллов)