50 баллов. Нужно написать программу ** питоне. Около стены наклонно стоит палка длиной...

0 голосов
215 просмотров

50 баллов. Нужно написать программу на питоне. Около стены наклонно стоит палка длиной 4,5 м. Один ее конец находится
на расстоянии 3 м от стены. Нижний конец палки начинает скользить в
плоскости, перпендикулярной стене. Определить значение угла между пал-
кой и полом (в градусах) с момента начала скольжения до падения палки че-
рез каждые 0,2 м.


Информатика (24 баллов) | 215 просмотров
0

Вижу только 5 + 3 балла :)

Дан 1 ответ
0 голосов

import math

lengthstick = 4.5

distance = 3

cosina = distance / lengthstick

while (cosina < 1):

   distance = distance + 0.2

   cosina = distance / lengthstick

   if (cosina > 1):

       break

   print("Radians: " + str(round(cosina,3)) + " Degrees: " + str(round(math.degrees(math.acos(cosina)))))


(804 баллов)