Срочно! Помогите написать программу в паскале с данной блок схемой.

0 голосов
44 просмотров

Срочно! Помогите написать программу в паскале с данной блок схемой.


image

Информатика (432 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var

   x,y:real;


begin

   readln(x);

   if x > 0 then

       y := sqr(x) * 4

   else if x < 0 then

       y := x*x - 8

   else

       y := 12 / (x - 1); (*здесь x-1, потому что на 0 делить нельзя*)

   writeln('x = ', x:2);

   writeln('y = ', y:2);

end.


image
(4.0k баллов)
0

(readln(x);

if x > 0 then)

0

Ошибку узнать-то можно?

0

ожидался символ ' '

0

При копировании из редактора добавляются новые символы. Напишите код вручную.

0

ошибка не исправляется..Почему?

0

Ошибка та же?

0

та же

0

Я прикрепил скриншот, где видно, что у меня все работает.

0

Компилятор у вас какой?

0

??