Программа в Паскале Составить программу проверки знания таблицы умножения. Сценарий:...

0 голосов
94 просмотров

Программа в Паскале
Составить программу проверки знания таблицы умножения. Сценарий: компьютер спрашивает: «Проверим?» (варианты ответов: 0 – «нет», 1 – «да») . Если играющий отвечает «да», то компьютер с помощью генератора случайных чисел задает 2 числа и запрашивает их произведение. После проверки правильности ответа компьютер сообщает «правильно» или «неправильно» и подсчитывает количество правильных ответов и ошибок. Затем компьютер вновь спрашивает: «Проверим?». По окончании работы цикла компьютер выдает статистику игры: сколько всего задано вопросов, количество правильных ответов и число ошибок. Благодарю☺☻


Информатика (22 баллов) | 94 просмотров
0

Олег Деревенец "Песни о Паскале", там есть, гугол в помощь

Дан 1 ответ
0 голосов

//Язык Pascal

Program multiplication;


Var

  code, rightAnswers, mistakes, answersCount, value1, value2, answer: integer;


Begin


  Randomize;

   

  code := 1;

  rightAnswers := 0;

  mistakes := 0;

  answersCount := 0;

   

  while code = 1 do

  begin

     Write('Проверим? ');

     Readln(code);

     Writeln();

     

     if (code = 1) then

     begin

        value1 := random(1, 9);

        value2 := random(1, 9);

         

        Write(value1, '*', value2, ' = ');

        Readln(answer);

         

        if (answer = value1 * value2) then

        begin

           Writeln('Правильно!');

           rightAnswers := rightAnswers + 1;

        end

         

        else

        begin

           Writeln('Неправильно!');

           mistakes := mistakes + 1;

        end;

         

        answersCount := answersCount + 1;

        Writeln();

     end;

  end;

   

  Writeln('Статистика:');

  Writeln('Задано вопросов: ', answersCount);

  Writeln('Количество правильных ответов: ', rightAnswers);

  Writeln('Число ошибок: ', mistakes);


End.


image
image
(13.4k баллов)