Написать программу ** языке C++ и создать блок-схему для следующей функции: ...

0 голосов
81 просмотров

Написать программу на языке C++ и создать блок-схему для следующей функции:

F={-a*x^2+b^3 при x<-10 и b неравно 0; <br> (x/(x-c))-a при x>0 и b=0;
-(|x|*x^2)/c в остальных случаях}


Информатика | 81 просмотров
0

Это система?

0

И какие переменные инициализируем с клавиатуры?

0

Это система, просто я так расположил

0

А иницианизируем переменные а, b, c, x

0

ок

0

домой приду, если никто не сделает, скину решение

Дан 1 ответ
0 голосов

#include

#include

#include


int main()

{

float

 a, b, c, x,

 f = 0.0f;

std::cout << "Введите значения переменных A, B, C, X: ";</p>

std::cin >> a >> b >> c >> x;


if(x < - 10 && b != 0)

 f = -a * pow(x, 2) + pow(b, 3);

else if(x > 0 && b == 0)

 f = x / ((x-c) - a);

else f = -(abs(x) * pow(x, 2)) / c;


std::cout << "Значение переменной f = " << std::setprecision(3) << f << std::endl;</p>

}

g++ compiler

В общем, я не знал, как сохранить блок-схему в фотку, поэтому держи так. Просто срисуй, если нужно. Уж извиняй :)


image
image
(4.0k баллов)
0

О, короче, я забыл стрелки провести от прямоугольников к "Конец"