Написать программу, которая использовает оператор while, решение уравнения : y = 1- x + x...

0 голосов
31 просмотров

Написать программу, которая использовает оператор while, решение уравнения : y = 1- x + x * x / 2 + 5x, при -5 < x < 6.


Информатика (33 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

#include

#include


int main()

{

   // y = 1 - x + x * x / 2 + 5x

   // -5 < x < 6


   // Считываем x:

   float x;

   printf("Enter x: ");

   scanf("%f", &x);


   // Проверяем условие с помощью цикла while:

   // PS: для извращенцев.

   int i = 0;

   while (i == 0)

   {

       if (-5 >= x)

       {

           return EXIT_FAILURE;

       }

       if (x >= 6)

       {

           return EXIT_FAILURE;

       }

       i = 1;

   }


   // Решаем уравнение:

   float y = 1 - x + x * x / 2 + 5 * x;


   // Выводим результат:

   printf("Result y = %f\n", y);

}

(132 баллов)