Написать программу, которая использовает оператор while решение уравнения : y = 1- x + x...

0 голосов
68 просмотров

Написать программу, которая использовает оператор while решение уравнения : y = 1- x + x * x / 2 + 5x, при -5 < x < 6.
С оъяснением пожалуйста помогите.


Информатика (33 баллов) | 68 просмотров
0

значит скорее всего PHP

0

Сейчас постараюсь помочь

0

Да что же упертость? НЕЛЬЗЯ это решить "просто так". Нужно указать численные методы для: 1) отделения корней 2) нахождения каждого корня с заданной точностью 3) задать эту точность

0

Вы понимаете, нам так было дано, училка нам так дала задачу, я вас прошу решите мне её как - то, чтобы она мне поставила 4

0

о черт, с мат. частью PHP у меня проблемы, сорри

0

Я думаю, формулу Вы переврали. Фотку прикрепите с формулой

0

Эникей, я так понимаю, что нужно просто подставлять значения X в функцию в цикле while, исключая Ваши моменты, описанные выше

0

Неочевидно. Задан интервал, а не два дискретных значения. Либо поиск корня, но тогда уравнение надо, либо табуляция, тогда нужен шаг.

0

И еще раз, скорее всего там деление относится не только к х, но гадать мы права не имеем.

0

Собственно, как Вы знаете, окончательное решение остается за модератором, у остальных - только мнения.

Дан 1 ответ
0 голосов

a, b, c, d: integer;

x1, x2: real;

begin

readln(a);

readln(b);

readln(c);

d:=(b*b)+(-4*a*c);

if d>0

then begin

x1:=(-b+sqrt(d))/(2*a);

x2:=(-b-sqrt(d))/(2*a);

writeln(x1);

writeln(x2);

end;

if d=0

then begin

x1:=(-b/2*a);

x2:=0;

writeln(x1);

writeln(x2);

end;

if d

then begin

write('корней нет');

end;

end.

Вот как то так

(132 баллов)