Please help. Написать программу ** языке С++ для расчёта значений данной функции.

0 голосов
45 просмотров
y = 1.5 {cos}^{2} x + b {a}^{1.5x} \times x
Please help. Написать программу на языке С++ для расчёта значений данной функции.

Информатика (17 баллов) | 45 просмотров
0

x, b, a с клавиатуры ввод?

0

a=2.3; b=1.8; x-ввод с клавиатуры

Дан 1 ответ
0 голосов
Правильный ответ

#include

#include

#include


int main()

{

   float

       x, y, b, a;

   

   std::cout << "Введите X, A, B: ";</p>

   std::cin >> x >> a >> b;

   

   y = 1.5*pow(cos(x), 2) + b*pow(a, 1.5*x) * x;

   

   std::cout << "Значение функции = " << std::setprecision(3) << y;</p>

   

   return 0;

}

(4.0k баллов)
0

Ну ты и любитель усложнять :)

0

это да)))

0

Че здесь сложного?))))))

0

эх, я косякнул сам :(

0

ну библиотеку для кириллицы не подключил, у человека трабл будет.

0

и с выводом заморочился :)

0

Не знаю. Я уже 100 лет библиотеку с локалью не использую, ибо все проходит.
Автор, если будут проблемы с кириллицей:
#include под последний include
в int main:
setlocale(LC_ALL, "Russian");

0

что за ide?

0

спес))0)

0

Онлайн компилятор использую. Вообще, кириллица от кодировки зависит. Поэтому более правильно менять кодировку в самой консоли. Но предполагаю, что в вин10 кодировка стоит уже нормальная. Надо почитать про это все дело, а то не силен в этом :(