Пхах, теперь только про программирование и буду спрашивать С++ Составить программу....

0 голосов
103 просмотров

Пхах, теперь только про программирование и буду спрашивать

С++
Составить программу.
(Один любой номер)


image

Информатика (148 баллов) | 103 просмотров
Дано ответов: 2
0 голосов

4/2/1

Ничего лучше не придумал, как:

#include



int main()

{

   int

       N;

   std::cin >> N;

   

   switch(N)

   {

       case 1:

       case 21:

       {

           std::cout << "Мы сдали " << N << " экзамен";</p>

           break;

       }

       case 2: case 3: case 4: case 22: case 23: case 24:

       {

           std::cout << "Мы сдали " << N << " экзамена";</p>

           break;

       }

       case 5: case 6: case 7: case 8: case 9: case 10:

       case 11: case 12: case 13: case 14: case 15: case 16: case 17: case 18: case 19: case 20:

       {

           std::cout << "Мы сдали " << N << " экзаменов";</p>

           break;

       }

   }

   return 0;

}


(4.0k баллов)
0

Хах, сегодня ты мой спаситель и герой! (^_^) Спасибо огромное тебе)))))))

0

Не за что

0 голосов

Универсальный вариант для 1, 3, 4, 5, 6, 7, 9, 10 заданий, нужно только в правильном месте поменять текст, и в нужном месте его добавить.

#include


int main() {

setlocale(0, "");


int n;


std::cin >> n;

n = n % 100;


std::cout << "Мы успешно сдали " << n;</p>

switch (n)

{

case 11: case 12: case 13: case 14:

 std::cout

 break;

default:

 n = n % 10;

 switch (n)

 {

 case 1:

 std::cout

 break;

 case 2: case 3: case 4:

 std::cout

 break;

 default:

 std::cout << " экзаменов";</p>

 break;

 }

}


std::cout << std::endl;</p>

return 0;


}

(5.8k баллов)
0

Это для какого задания?И да, прикол был именно с переключателем