С++,кто разбирается,помогите Нужно написать программу,для примера 1

0 голосов
53 просмотров

С++,кто разбирается,помогите
Нужно написать программу,для примера 1


image

Информатика (37 баллов) | 53 просмотров
Дано ответов: 2
0 голосов

#include



#include



int main()



{



  float



      X,



      Y;



  std::cout << "Введите значение переменной X: ";</p>

  std::cin >> X;



Y = 3*( (sqr( sin(X) ) * sin(X) ) + ( sqr( cos(2*X) ) / 2) );



std::cout  << setprecision(3) << "Результат = " << Y;</p>

return 0;



}

(4.0k баллов)
0

sqrt -- это корень...

0

sqr*

0

Изменил. Извиняюсь, очень глупая ошибка :)

0 голосов

#include
#include
using namespace std;

int main( )
{
double x, y;
cout << "Vvedite x: ";<br>cin >> x;
y = 3*(pow(sin(x), 3) + 0.5*pow(cos(2*x),2));
cout << "y = " << y << endl;<br>return 0;
}

Пример:
x = 0
y = 1.5

(41.5k баллов)
0

conio.h для каких целей подключен?

0

А, убрать забыл, сначала хотел добавить getch