Помогите написать ** ПаскалеДано N пицц Пиццу резать нельзя ! Если распределить пиццы...

0 голосов
55 просмотров

Помогите написать на Паскале
Дано N пицц Пиццу резать нельзя ! Если распределить пиццы поровну среди М друзей , то по скольку пицц получит каждый друг и сколько пицц окажутся не распределенными ? Программа получает на вход два натуральных числа N и M , при чем N > M. N не превосходит 10 9 Программа должна вывести два числа- сколько пицц достанется каждому другу и сколько пицц останется не распределенными через пробел


Информатика (14 баллов) | 55 просмотров
0

не превосходит 109 или 10?

0

10 в 9 степени

Дан 1 ответ
0 голосов

До нельзя просто. div находит целое число от деления, mod — остаток. Путём деления и находим, кто сколько пицц скушает =)

program Pizza2friends;

var N,M:integer;

begin

writeln('Введите количество пицц');
read(N);
writeln('Введите количество друзей');
read(M);

if N > M then
writeln('У каждого друга будет ',N div M,' пицц. Останется ',N mod M,' ничьих пицц.')

else writeln('Пицц должно быть больше, чем друзей');

end.

(1.2k баллов)
0

добавьте условие что N не превосходит 10^9

0

program Pizza2friends;
var N,M:integer;
begin
writeln('Введите количество пицц');
read(N);
writeln('Введите количество друзей');
read(M);
if (N > M) and (N < exp(ln(10) * 9)) then
writeln('У каждого друга будет ',N div M,' пицц. Останется ',N mod M,' ничьих пицц.')
else writeln('Пицц должно быть больше, чем друзей и N не должно превышать 10^9.');
end.