Написать программу, которая сортирует записи в файле F по алфавиту по фамилиям.

0 голосов
59 просмотров

Написать программу, которая сортирует записи в файле F по алфавиту по фамилиям.


Информатика (569 баллов) | 59 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET

// Версия 3.4 сборка 1749 (18.08.2018)


begin

var (f, out) := (ReadAllLines('in.txt'), OpenWrite('in.txt'));

f.Select((t, i)-> (t.ToWords[0], i)).Sorted.ForEach(t -> begin Writeln(out, f[t[1]]) end);

out.Close;

end.


Файл, который использовал для проверки в приложении(совпадение с реальными именами - случайность).

Считывание и запись происходит в одном файле.


Скачать вложение Текст (TXT)
(5.8k баллов)