Написать программу в который будет спрашиваться кол-во чисел в массиве. Числа будут...

0 голосов
35 просмотров

Написать программу в который будет спрашиваться кол-во чисел в массиве. Числа будут вводится в ручную, а потом среди них выведется которое делится на 9 без остатка.

С#


Информатика (18 баллов) | 35 просмотров
0

Какой язык?

0

С#

0

Поможешь ?

0

Не, сорри, не знаю С#

0

Ещё раз для тупых. Сначала вводится количество чисел в массиве, потом числа. Я правильно понял

Дан 1 ответ
0 голосов

Лови:

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Threading.Tasks;

namespace ConsoleApp3

{

class Program

{

static void Main(string[] args)

{

Console.WriteLine("Введте длину массива:");

int a = Convert.ToInt16(Console.ReadLine());

int[] array = new int[a];

Console.WriteLine("Введите массив:");

for(int i = 0; i < a; i++)

{

array[i] = Convert.ToInt16(Console.ReadLine());

}

Console.WriteLine("Числа делящиеся на 9 без остатка:");

for(int i = 0; i < a; i++)

{

if(array[i]%9 == 0)

{

Console.WriteLine(array[i]+" ");

}

}

}

}

}

(34 баллов)