На языке программирования Pascal составить программу, которая проверяет, является ли введенное с клавиатуры число простым или нет (т. е. число делится только на 1 и на само себя без остатка) (число 354)
function isPrime(n:integer):boolean;
var res:boolean;
i:integer;
begin
if n>1 then res:=true
else res:=false;
for i:=2 to n div 2 do
if n mod i = 0 then
res:=false;
break;
end;
isPrime:=res;
var n:integer;
writeln('введите целое число: n = ');
readln(n);
write(isPrime(n));
readln;
end.