Нужно сделать задачу в CodeBlocks, ** языке C (не C++) Сама задача:"Написать программу,...

0 голосов
37 просмотров

Нужно сделать задачу в CodeBlocks, на языке C (не C++)
Сама задача:

"Написать программу, которая проверяет, является ли год високосным.
Ниже приведен рекомендуемый вид экрана во время
работы программы. Данные, введенные пользователем, выделены
полужирным шрифтом.
Введите год, например 2000, и нажмите
-> 2001
2000 год - не високосный"
Желательно объяснение еще функций, переменных и т.д


Информатика (12 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

#include

main() {

int y; // Переменная, в которой будет хранится год

scanf("%d",&y); // Вводим год

if (y%4 != 0) printf("Обычный"); // Проверяемый на високосный ли год

else

if (y%100 == 0 && y%400 != 0) printf("Обычный"); // Проверяем год на исключения

else printf("Високосный");

printf("\n");

}

(817 баллов)
0

А как добавить перед "Обычный" "Высокосный" введенный год?

0

printf("Обычный %d", y) или printf("Високосный %d", y)

0

Спасибо большое