Написать программу, которая проверяет является ли строка, введенная с клавиатуры...

0 голосов
69 просмотров

Написать программу, которая проверяет является ли строка, введенная с клавиатуры палиндромом (пробелы игнорировать). Pascal ABC


Информатика (12 баллов) | 69 просмотров
Дан 1 ответ
0 голосов

Var
  s:string;
  i,n:byte;
  p:boolean;
begin
  Write('Введите строку: ');
  Readln(s);
  n:=Length(s);
  for i:=n downto 1 do
    if s[i]=' ' then Delete(s,i,1);
  n:=Length(s);
  p:=true;
  for i:=1 to n div 2 do
    if s[i]<>s[n-i+1] then
    begin
      p:=false;
      break
    end;
  if p then Writeln('Палиндром')
  else Writeln('Не палиндром')
end.

(2.0k баллов)