Написать программу, которая выводит пример ** умножение двух однозначных чисел, которые...

0 голосов
153 просмотров

Написать программу, которая выводит пример на умножение двух однозначных чисел, которые выбираются случайным образом, запрашивает ответ пользователя, проверяет его и выводит сообщение «Правильно!» или «Вы ошиблись» и верный результат. Pascal ABC


Информатика (12 баллов) | 153 просмотров
Дан 1 ответ
0 голосов

Var
  a,b,r:byte;
begin
  randomize;
  a:=Random(9)+1;
  b:=Random(9)+1;
  Write(a,' x ',b,' = ');
  Readln(r);
  if r=a*b then Writeln('Правильно!')
  else Writeln('Вы ошиблись. Верный результат ',a*b)
end.

(2.0k баллов)