Написать программу которая определяет сторону и площадь квадрата если известна диагональ...

0 голосов
45 просмотров

Написать программу которая определяет сторону и площадь квадрата если известна диагональ . На паскале !


Другие предметы (12 баллов) | 45 просмотров
Дан 1 ответ
0 голосов

Program square;
var d, a, S: real;
begin
writeln('Введите длину диагонали:');
readln(d);
a:= d*sqrt(2)/2;
S:= sqr(a);
writeln('Сторона = ', a:0:3, '. Площадь = ', S:0:3, '.');
end.

(8.7k баллов)