Написать программу в Паскале 1. Заданы стороны треугольника. Проверить является ли он...

0 голосов
44 просмотров

Написать программу в Паскале 1. Заданы стороны треугольника. Проверить является ли он прямоугольным


Информатика (45 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.4.0, сборка 1675 от 12.06.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrReal('Введите длины сторон:',3);
  a.Sort;
  if Sqr(a[2])=Sqr(a[0])+Sqr(a[1]) then Writeln('Треугольник прямоугольный')
  else Writeln('Треугольник не прямоугольный')
end.
(150k баллов)