Напишите программу, которая о трех числа решает могут ли они быть сторонами...

0 голосов
25 просмотров

Напишите программу, которая о трех числа решает могут ли они быть сторонами прямоугольного треугольника. Напишите программу так чтобы любое число могло быть гипотенузой. паскаль


Информатика (34 баллов) | 25 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadSeqInteger('Введите стороны прямоугольника',3).Sorted.ToArray;
  if Sqr(a[2])=Sqr(a[0])+Sqr(a[1]) then Writeln('Могут')
  else Writeln('Не могут')
end.

image
(150k баллов)