PascalABC.NET Составить программу, которая печатает true, если точка с координатами (х,...

0 голосов
183 просмотров

PascalABC.NET
Составить программу, которая печатает true, если точка с координатами (х, у) принадлежит заштрихованной области, и false в противном случае.


image

Информатика (1.3k баллов) | 183 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
PascalABC.NET 3.4.0, сборка 1670 от 23.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (x,y):=ReadReal2('Введите x и y через пробел:');
  Writeln(x.Between(-6,-1) and y.Between(2,7) or
      x.Between(-6,-3) and y.Between(-3,2))
end.
(150k баллов)
0

Границы заштрихованных областей считаются принадлежащими этим областям.

0

Выражение х.Between(a,b) возвращает True, если х принадлежит интервалу [a;b]

0 голосов

Var
  x, y: real;

begin
  write('x: ');
  readln(x);
  write('y: ');
  readln(y);
  if ((x >= -6) and (x <= -1)) and ((y <= 7) and (y >= 2)) or (((x <= -3) and (x >= -6)) and ((y >= -3) and (y <= 2)))<br>    then writeln('True')
  else writeln('False');
end.

Подробнее - на Znanija.com - znanija.com/task/29163596#readmore

(2.3k баллов)