Составить программу, используя оператор REPEAT. Вводятся числа до тех пор пока не...

0 голосов
56 просмотров

Составить программу, используя оператор REPEAT. Вводятся числа до тех пор пока не введется 0. Определить, сколько среди них положительных (включая 0) и сколько отрицательных. (Числа вводятся в одну переменную в цикле).


Информатика (12 баллов) | 56 просмотров
Дан 1 ответ
0 голосов

Вот так можно решить

Program M;
var i : integer = 0;
    pologitelnie : integer = 0;
    otricatelnie : integer = 0;    a : array[0..100] of Integer;
begin
    repeat
        begin
        read (a[i]);
        if (a[i]>=0) then
            pologitelnie := pologitelnie + 1
        else
            otricatelnie := otricatelnie + 1;
        i := i + 1;
        end;
    until a[i-1] = 0;
    writeln('положительных: ', pologitelnie);
    writeln('отрицательных: ', otricatelnie);
end.

(898 баллов)