Срочно, пожалуйста, информатика.Напишите программу, вычисляющую значение функции (**...

0 голосов
30 просмотров

Срочно, пожалуйста, информатика.

Напишите программу, вычисляющую значение функции (на фото)

Тема: условный алгоритм


image

Информатика (3.8k баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  a,b,y:real;
begin
  Read(a,b);
  if a>1 then y:=a+b else y:=a-b;
  Writeln(y)
end.

var
  x,b,y:real;
begin
  Read(b,x);
  if x<100 then y:=b*b-Abs(x)<br>  else y:=x*Sqr(Sqr(x))-3*b;
  Writeln(y)
end.

(150k баллов)
0

Я у вас в долгу.

0

Ничуть

0

Почему вместо 5 степени sqr?

0

Потому что нет в Паскале способа писать степень выше 2. Чтобы возвести в пятую, возводим в х квадрат, результат снова в квадрат и получаем четвертую. Умножая на х, получаем пятую.

0

Sqr - это квадрат.

0

Можно, конечно, возводить в степень через основное логарифмическое тождество, но про х ничего неизвестно, значит, он может быть и неположительным, а логарифм неположительного числа не существует... в общем, это проблемнее.

0

Поняла, спасибо

0

Пожалуйста