1)Напишите программу, которая выводит ** экран имя вашего любимого киногероя. 2)В...

0 голосов
151 просмотров

1)Напишите программу, которая выводит на экран имя вашего любимого киногероя.
2)В алгоритме, записанном ниже, используются целочисленные переменные k и m. Определите значение переменной m после исполнения данного алгоритма.
k:=3
m:=k+1
k:=m*m+5
k:= k-10
Зарани спасибо.


Информатика (14 баллов) | 151 просмотров
0

по мне так первая задача бред

Дан 1 ответ
0 голосов

1. 
var
   Hero:string;
begin 
   writeln('Введите имя вашего любимого киногероя: '); 
   readln(Hero); 
   writeln('Ваш любимый киногерой: ', Hero, '!');
end.

2. 
k:=3; m:=k+1; → m:=3+1; // m = 4;
k:=m*m+5; → k:= 4*4+5; //k = 21;
k:= k-10; → k:= 21-10; // k = 11;
Нам надо было найти значение, хранящееся в переменной m: m = 4.

(1.8k баллов)