Напишите программу по информатике: ** координатной прямой задаются 2 точки, являющимися...

0 голосов
63 просмотров

Напишите программу по информатике: На координатной прямой задаются 2 точки, являющимися противооположными углами прямоугольника.Найти площадь и периметр полученного прямоугольника


image

Информатика (12 баллов) | 63 просмотров
0

быстрее

0

пж

Дан 1 ответ
0 голосов

Если по картинке первая точка находится сверху левого угла, а правая противоположна, то можно такprogram znanijatop;var x1,y1,x2,y2,a,b:byte;begin
writeln('введите координату по Х1,Y1,X2,Y2');readln(x1);readln(y1);readln(x2);readln(y2);a:=x2-x1;b:=y1-y2;writeln('P =  ',a+a+b+b,' S = ',a*b);end.




(4.4k баллов)
0

спасибо