Решите задачу , используя необходимую подпрограмму. Напишите программу, которая выведет...

0 голосов
46 просмотров

Решите задачу , используя необходимую подпрограмму.
Напишите программу, которая выведет на экран n символов X в указанном ниже порядке:
X
XX
XXX
...n
XXX
XX
X
Буду безумно благодарна


Информатика (41 баллов) | 46 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var i,n,j:integer;
begin
readln (n);
for i:=1 to n do
begin
for j:=1 to i do write ('X');
writeln
end;
for i:=n downto 1 do
begin
for j:=1 to i do write ('X');
writeln
end
end.

(3.9k баллов)
0

Спасибо огромное

0 голосов

Если я не ошибаюсь то ета програиип назвается Excel

(18 баллов)